Back
Maintenance

UPDATE WEBFLOW DNS

Completed 19 Oct at 06:04pm GMT+8.

staple.io
Completed

Maintenance completed

Posted 19 Oct at 06:04pm GMT+8.
Started

We need to update the new DNS on webflow as per requirement of their new change

Posted 19 Oct at 05:15pm GMT+8.