Back
Resolved

Staple User interface loading slowly

Started 19 Mar at 06:25pm GMT+8.

staple.io
Created

Staple is currently being slow to respond due to high demand in the system. We are working to update backlog of requests and it should be resolved shortly

UPDATE:
This issue is now resolved

Posted 19 Mar at 06:25pm GMT+8.