Back
Maintenance

Schedule maintenance on Sunday 25th June 8.00 am - 10.00 am (GMT+8)
Completed 25 Jun at 10:00am GMT+8.
staple.io
Completed
Maintenance completed
Posted
25 Jun at 10:00am GMT+8.

Started
Please be informed that Staple will be unavailable on Sunday 25th June 2023 during 8.00 am - 10.00 am (GMT+8 Singapore Time) as the IT team will be performing scheduled maintenance at this time.
During this time, you will be unable to access the application. Before maintenance takes place, please make sure you complete your work. The IT team will advise when the maintenance is complete, and services have been restored.
We apologize for any inconvenience caused.
For more information, or if you have any questions, please contact hello@staple.io
Posted
25 Jun at 08:00am GMT+8.